We're updating the issue view to help you get more done. 

Update rubocop to 0.49.0

Description

There is a known low severity security vulnerability in rubocop < 0.48.1 defined in Gemfile.

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-8418

Release Notes

None

Activity

Show:
Derek Wood
November 16, 2017, 9:24 PM

We only constrain it for testing on Ruby 1.9.3, since rubocop 0.42 and up requires ruby 2.0. But I think it's pointless anyway to be testing multiple ruby versions. We should either switch to testing Chef versions as we do for hadoop_wrapper, or I believe may have a testing revamp coming anyway.

Derek Wood
March 31, 2018, 1:36 AM
Fixed

Assignee

Derek Wood

Reporter

Matt Wuenschel

Labels

None

Docs Impact

None

UX Impact

None

Components

Priority

Major
Configure