We're updating the issue view to help you get more done. 

issues with hadoop cookbook on ubuntu 16

Description

The _compression_libs.rb recipe fails on ubuntu 16 because they changed the name of the libsnappy1 package to libsnappy1v5.

The following will solve this issue:

Release Notes

None

Activity

Show:
Derek Wood
July 27, 2017, 11:39 PM

Thanks for reporting! This code LGTM if you'd like to submit a github PR (to get the credit). Otherwise i'll submit one soon and we can get this patched.

Also note, if you are using HDP, this illuminated another issue I just created https://issues.cask.co/browse/COOK-127 for.

Greg Wohletz
July 28, 2017, 4:39 PM

i'm using CDH, PR submitted

Derek Wood
July 29, 2017, 2:03 AM

Thanks for the fix. Merged and released in v2.11.3

Fixed

Assignee

Derek Wood

Reporter

Greg Wohletz

Labels

None

Docs Impact

None

UX Impact

None

Components

Priority

Minor
Configure