Need to filter Cask Market entities based on supported CDAP Version

Description

Currently, every pipeline in Cask Market is specifying the artifact version in the pipeline config with 4.0.0 version of cdap-data-pipeline artifact. This becomes a problem in any of the next version of CDAP.

We need to come up with a better solution so that there is some backward compatibility of the Cask Market entities with different version of CDAP

Release Notes

The Cask Market now shows only those entities that are valid for the specific version of CDAP viewing them.

Activity

Show:
Albert Shau
December 28, 2016, 9:03 PM

everything has to be versioned in order for it to be guaranteed to be correct. A new hydrator version will require new market packages. This was the intent behind the cdapVersion property in a package specification, where the UI is supposed to filter out packages that are not compatible with the version of CDAP running.

Edwin Elia
December 28, 2016, 10:08 PM

Thanks Albert! That makes sense. UI will have to implement that filtering by cdapVersion

Edwin Elia
January 25, 2017, 7:07 PM
Edited

PR: https://github.com/caskdata/cdap/pull/7679

Fixed on 4.1.0, need to port to 4.0.2

Fixed

Assignee

Edwin Elia

Reporter

Edwin Elia

Labels

None

Docs Impact

None

UX Impact

None

Components

Sprint

None

Fix versions

Priority

Critical