I have implemented the RecordScannable interface in a custom Dataset. The RecordType class that I have implemented and return the type in getRecordType has a String variable named "column". When I deploy the application I see the Dataset, but it is not explorable. If I change the name to something else like "col" the Dataset is explorable.
Can you please document any variable names that should not be used for RecordType classes?
I think that happens for all names that are reserved keywords in Hive:
On that page, it also says: Reserved keywords are permitted as identifiers if you quote them.
Perhaps we should always do that when generating the DDL statement?
Also wondering whether CDAP gives a reasonable warning message in the logs about that? Or would it be better if it fails because of that, so that the user can fix it right away and it does not go unnoticed?
There was no error message that I could find in the cdap master log.
My understanding is that the application deploy should have failed.
Isn't that right? In that case, cdap master would not need an error log.
Ever since we introduced explore, explore failures have not been treated as fatal failures, which is why the application deploy did not fail. I'm not sure why we did it that way, but it is worth revisiting. Seems like an explore failure should fail app deployment, dataset property update, etc.