We're updating the issue view to help you get more done. 

Cloning an old pipeline displays incompatible plugins

Description

To reproduce:

1. deploy the attached pipelines to a 6.3.0 CDAP. The pipelines has 6.2.2 as the cdap-data-pipeline version.

2. Clone the pipeline.

3. The UI will update the source/sink to 0.16.0, which is not compatible with 6.2.2.

4. Deploy the pipeline, it will fail with a confusing message that the plugin could not be found, even though the UI is displaying it.

Release Notes

None

Assignee

Ajai Narayanan

Reporter

Albert Shau

Labels

None

Docs Impact

None

UX Impact

None

Components

Priority

Major
Configure