We're updating the issue view to help you get more done. 

Select latest version of the plugin as default from pipeline studio

Description

We don't have the capability to choose the latest version of the plugin (if there are multiple versions) while selecting the plugin from pipeline studio. UI defaults to the first artifact (from the list of artifacts) returned by the backend.

https://github.com/cdapio/cdap/blob/develop/cdap-ui/app/cdap/services/VersionRange/VersionUtilities.js#L19 We can use this utility to select the latest version from a list of version we have in UI.

Release Notes

UI now adds the latest version of plugin, among the list of different versions of the plugin, when added from the sidepanel in pipeline studio. If the user has already chosen a specific version (older version) it defaults to that instead of the latest.

Activity

Show:
Ajai Narayanan
June 16, 2020, 7:46 AM
Ajai Narayanan
June 17, 2020, 4:22 AM
Fixed

Assignee

Ajai Narayanan

Reporter

Ajai Narayanan

Labels

None

Docs Impact

None

UX Impact

None

Components

Fix versions

Priority

Major
Configure